均线与RSI相对强弱指数组合策略的运用

均线与RSI的结合运用

关于均线策略,在以往的文章中,已经多次提到且有很多实战策略可供各位读者选择,均线策略由于在趋势跟踪方面有很大的优势,一直被众多CTA策略爱好者所重视,但是对于市场来讲,大部分时间还是震荡居多,我们有必要加入一些对于震荡判断的指标结合趋势策略来使用。这样不仅会加大潜在的盈利能力,还会对于资金管理有莫大的好处。使资金使用率和安全性有很大的提升。

在本文中,我们将介绍最受欢迎的振荡器之一:相对强弱指数(RSI)。您可能已经阅读了一些关于RSI的一般性文章;但是,在这篇文章中,我将介绍交易时可以使用的一种可以在发明者量化平台结合均线策略部署的交易策略。

RSI指标的原理与运用

在我们深入研究策略之前,让我们首先了解RSI指标,并为您提供一些基本的介绍。

相对强弱指数(RSI)是市场上最受欢迎的指标之一。

RSI是通过比较上涨天数与下降天数的强弱来衡量一个交易标的对自身表现的基本指标。该数字是计算出来的,其范围在0到100之间。高于70的读数被认为是看涨的,而低于30的读数则表示看跌

相对强弱指数公式

RSI由J.Welles Wilder开发,并于1978年6月在他的“技术交易系统新概念”一书中详述。对于所有硬核技术分析人员,下面是相对强度指数公式的例子。

RSI的默认设置为14天,因此您可以根据以下公式计算:

相对强度 = 1.25(过去13根K线平均涨幅)+ 0.25(当前涨幅)/(0.75(过去13根K线平均跌幅)+ 0(当前跌幅))

相对强度= 1.50 / 0.75 = 2

RSI = 100 - [100 /(1+2)] = 66.67

现在我们知道相对强度指数公式,让我们分析如何使用这个强大的指标。

大多数交易者使用相对强弱指数只需在指标达到30时买入交易标的并在达到70时卖出,但是如果你这样做了,根据这个规则买入或者卖出,您将产生亏损。市场不会奖励任何人那些显而易见的事情。这并不意味着简单的方法不起作用,但所有人都遵循的简单方法具有较低的赔率。所以如开头所说,我们需要引入均线来辅助判断。

在发明者量化平台编写和运用均线加RSI策略

记下来,我们就把此策略部署到发明者量化平台,我们还是选用简单易懂的My语言进行编程。

  • 策略名称:均线与RSI相对强弱指数组合策略
  • 周期:15分钟,30分钟,等等
  • 支持:商品期货,数字货币


主图:

MA 1, formula: MA1 ^^ EMA (C, N1);
MA 2, formula: MA2 ^^ EMA (C, N2);

副图:

RSI, formula:
RSIVALUE:SMA(MAX(CLOSE-REF(CLOSE,1),0),LENGTH,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),LENGTH,1)*100;

源码:

MA1^^EMA(C,N1);
MA2^^EMA(C,N2);
 
LENGTH:=9;
OVERBOUGHT:=70;
OVERSOLD:=100-OVERBOUGHT;
RSIVALUE:SMA(MAX(CLOSE-REF(CLOSE,1),0),LENGTH,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),LENGTH,1)*100;
BUYK:=BKVOL=0 AND BARPOS>N2 AND MA1>MA2 AND C>MAX(MA1,MA2) AND CROSSUP(RSIVALUE,OVERBOUGHT);
SELLK:=SKVOL=0 AND BARPOS>N2 AND MA1<MA2 AND C<MIN(MA1,MA2) AND CROSSDOWN(RSIVALUE,OVERSOLD);
SELLY:=MA1<MA2 AND C>BKPRICE*(1+SLOSS*0.01);
BUYY:=MA1>MA2 AND C<SKPRICE*(1-SLOSS*0.01);
SELLS:=C<BKPRICE*(1-SLOSS*0.01);
BUYS:=C>SKPRICE*(1+SLOSS*0.01);
 
BUYK,BK;
SELLK,SK;
SELLY,SP(BKVOL);
BUYY,BP(SKVOL);
SELLS,SP(BKVOL);
BUYS,BP(SKVOL);

策略源码,请查看:https://www.fmz.com/strategy/128250

免责声明:信息仅供参考,不构成投资及交易建议。投资者据此操作,风险自担。

如果觉得文章对你有用,请随意赞赏收藏
相关推荐
相关下载
登录后评论
Copyright © 2019 宽客在线