[原创] 均幅指标策略框架

均幅指标(ATR)是取一定时间周期内的股价波动幅度的移动平均值,主要用于研判买卖时机。

均幅指标是显示市场变化率的指标,由威尔德(Welles Wilder)在《技术交易系统中的新概念》一书中首次提出,目前已成为众多指标经常引用的技术量。威尔德发现较高的ATR值常发生在市场底部,并伴随恐慌性抛盘。当其值较低时,则往往发生在合并以后的市场顶部。

由于惊恐购买所驱使的价格的剧烈下跌,这一指标在市场底部通常可以达到一个较高的价值。这一指标对于长期持续边幅移动的时段是非常典型的,这一情况通常发生在市场的顶部,或者是在价格巩固期间。平均波幅通道技术指标依据同样的原则,可以被解释成为其他一些易变指数。根据这个指标来进行预测的原则可以表达为:该指标价值越高,趋势改变的可能性就越高;该指标的价值越低,趋势的移动性就越弱。

计算公式:

t——当日;
n——时间长度;
Ci——第i日的收盘价;
Hi——第i日的最高价;
Li——第i日的最低价。

其中:
TRi = max(Hi,Ci-1)-min(Li,Ci-1)
注:一般取n=14
,m=6。

均幅指标无论是从下向上穿越移动平均线,还是从上向下穿越移动平均线时,都是一种研判信号。它表示价格运行趋势有可能发生逆转,具体如何转变需结合趋势类指标进行综合研判。

以下是一个在发明者量化平台运用My语言编写的基于均幅指标框架的交易策略:

LOTS:=MAX(1,INTPART(MONEYTOT/(O*UNIT*0.1)));
C_O:EMA(C,N)-EMA(O,N);
B:=CROSSUP(C_O,0);
S:=CROSSDOWN(C_O,0);
TR:=MAX(MAX((H-L),ABS(REF(C,1)-H)),ABS(REF(C,1)-L));
ATR:MA(TR,N);
BAND:=ATR*0.1*M;
PRICE_BPK:=VALUEWHEN(B,H+BAND);
PRICE_SP:=VALUEWHEN(B,L-BAND);
PRICE_SPK:=VALUEWHEN(S,L-BAND);
PRICE_BP:=VALUEWHEN(S,H+BAND);

// 策略逻辑
// strategy logic
BARPOS>N AND C_O>0  AND C>=PRICE_BPK,BPK(LOTS);
BARPOS>N AND C_O<0  AND C<=PRICE_SPK,SPK(LOTS);

// 下单
// place an order
S,SP(BKVOL);
B,BP(SKVOL);

C<=PRICE_SP,SP(BKVOL);
C>=PRICE_BP,BP(SKVOL);

更多信息,请查看:https://www.fmz.com/strategy/128136

我们运用发明者量化平台进行回测,可以看到:

以上使用的是国内商品期货的数据进行回测,可以看到结果是非常不错的,读者可以根据这个框架把策略移植到数字货币上,需要注意的是,数字货币市场大多是24小时连续交易,如果是数字货币期货,不纯在交割的问题,大部分主流数字货币交易所的期货合约都为连续合约。这反而为我们的策略减少了很多潜在的判断逻辑错误。

免责声明:信息仅供参考,不构成投资及交易建议。投资者据此操作,风险自担。

如果觉得文章对你有用,请随意赞赏收藏
相关推荐
相关下载
登录后评论
Copyright © 2019 宽客在线